Erfahrungen mit RTKnavi mit NEO7P und IGS

Fragen und Erfahrungen zur Anwendung von GPS beim Wandern, Radeln, Fliegen usw.

Moderator: Roland

Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 16.09.2014 - 13:03

Sehr geehrte Community,

ich habe ja mittlerweile viel gelesen, dass der PPP Algorithmus im RTKnavi nur mit einem zwei Frequenzempfänger zuverlässige Dezimeterbereiche errechnet. Allerdings teilen sich da wohl auch die Meinungen, da auch mit einem Einfrequenzempfänger durchaus Genauigkeiten unter einem Meter erreicht werden können. Hier möchte ich euch mal meinen Test präsentieren. Vielleicht habt ihr ähnliche Erfahrungen sammeln können, oder habt vielleicht auch eine Idee, was ich hier falsch mache. :?

Mein Ziel hier ist es mit den Korrekturdaten vom IGS FTP Server und dem PPP Algorithmus zuverlässig in dem Dezimeterbereich zu kommen.

Diesen Test habe ich über 2,5 Stunden aufgezeichnet mit einen Neo 7P und einer TW4421. Den Empfänger habe ich soweit in den Rohdatenmodus gesetzt und die Einstellungen im RTKnavi so wie im Bild gesetzt.

Bild


Allerdings ist das Ergebnis nicht unmittelbar zufriedenstellend, weil der sich der Punkt vom Referenzpunkt entfernt. Manchmal habe ich auch das Gefühl, dass wenn man beim Input den Haken bei correction raus nimmt, exakt die gleichen Positionen berechnet. Als ob das RTKnavi die Korrekturdaten gar nicht in die Berechnung mit einbezieht. Aber sollte es beim PPP-staic nicht so sein, dass er sich einem Punkt annähert? :(

Der Referenzpunkt wurde mit einer Laica TRX ausgemessen und konnte mit den SAPOS HEPS-Dienst und dem Ublox NEo7p nachvollzogen werden +-5cm :D .

Bild

Für eure Bemühungen bedanke ich mich schon im voraus :)
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon Yups » 17.09.2014 - 00:34

Was verwendest du da genau für einen Korrekturstream? -> okay, sind ultrapid clocks.
Versuche mal die Einstellung "Broadcast +SSR APC" unter Satellite Ephemeris/Clock. Sofern ich das Handbuch richtig verstanden habe, sorgt es erst dafür, dass der Korrekturstream genutzt wird.
Yups
 
Beiträge: 11
Registriert: 19.08.2014 - 22:42

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 18.09.2014 - 12:54

Hallo Yups,

vielen dank für Antwort. Mit der Einstellung habe ich das Problem, dass ich gar keine Lösung erhalte. :cry:
In der Dokumentation steht auf Seite 147, dass mit der Einstellung "Precise" die präzisen Daten verwendet werden, oder. :)

The precise ephemerides and clocks are applied in case that the processing option ʺSatellite
Ephemeris/Clockʺ to ʺPrecise



Ich muss aber auch gestehen, dass Englisch nicht so ganz mein fach war. :)


Weiß jemand was die Option "Ionex Tec" macht im RTKNAVI?
Laut Doku wird doch eine dazugehörige Datei mit zur Berechnung eingebunden, aber die kann man nur im RTKPOST einfügen. Ich habe keine Möglichkeit gesehen, diese auch in der RTKNAVI zu verwenden.
Runterladen kann man diese ja auch vom IGS Server: ftp://cddis.gsfc.nasa.gov/gps/products/ionex/2014/
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon ssquare_de » 18.09.2014 - 14:42

Hallo micha,


mit RTKLIBs PPP-Verfahren kenne ich mich noch kaum aus, zur Sache kann ich dir also hier noch nicht recht weiterhelfen.

Hast du von deiner hier vorgestellten Messung auch den ublox-Originaldatenlog aufgezeichnet und gespeichert?
Wenn ja, könntest du den als zweite Solution in RTKPLOT einlesen und hier zusammen mit der obigen Lösung darstellen?
Würde mich nur mal interessieren, wie das ublox´sche PPP-Verfahren sich so im Vergleich zu den externen Korrekturen schlägt.
Dazu brauchst du nur das ublox-Logfile von RTKPlot einlesen lassen.

Was anderes:
"Aber sollte es beim PPP-staic nicht so sein, dass er sich einem Punkt annähert?"

Rein theoretisch kann das ja auch bei deiner Messung passiert sein.
Dein "Messpunkt 18" wurde ja mit Hife von SAPOS-Korrekturen erstellt und liegt so in ETRS89 vor.
Deine PPP-Messreihe aber liegt mit einiger Wahrscheinlichkeit im ITRF2000 vor.
( Muss ich aber noch genauer nachsehen.)

---> Verschiedene Koordinatenlagerungen.
So kannste vermutlich nix belastbares zur Genauigkeit aus deinem Versuch ableiten, da der Kontinentalplattendrift (ERTS89=eurasische Platte) aus rund 25 Jahren unberücksichtigt bleibt. (ca. 2,5cm/Jahr in nordöstliche Richtung)


Stefan
ssquare_de
 
Beiträge: 671
Registriert: 07.10.2006 - 16:23

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 18.09.2014 - 15:10

Hallo Stefan,

leider habe ich den ublox-Originaldatenlog nicht aufgezeichnet, aber das Interessiert mich selber und werde es kurzerhand gleich mal testen. Aber leider nicht über 2 Stunden (je 30 min, denk ich), da ich an den 7P nur einen Port zur Verfügung habe, muss ich Zeitversetzt machen :). Der Vergleich kommt heute noch, hoffe ich.

Micha
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon ssquare_de » 18.09.2014 - 15:29

Hallo Micha,


nein, zeitgleich will ichs haben!!! :wink:

Ist doch auch kein Problem: du kannst ja in RTKNAVI den Datenstrom des NEO-7P mitschneiden.
Oder du spielst auf deinen Windows-Rechner die kleine Software "GPSGate Client Express" auf.
http://gpsgate.com/purchase/gpsgate_express_license

Kostet auch nix und stellt dir 2 virtuelle Com_Ports zur Verfügung.
Also ein Empfänger zeitgleich auf 2 Softwareanwendungen...z.B. RTKNAVI UND u-Center für den Log-Mitschnitt...spart dir auch die Zeit für den zweiten Log...
Oder du kannst einen doppelt langen Log aufzeichnen...noch besser
:-)


Stefan
ssquare_de
 
Beiträge: 671
Registriert: 07.10.2006 - 16:23

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 18.09.2014 - 17:24

OH Moment, aber um den Ublox Empfänger mit der RTKlib zum Leben zu erwecken muss ich doch den in den Rohdaten-Modus setzen, oder sehe ich das Falsch? Und dann ist doch der normale UBX modus hin, oder nicht?
Stehe etwas auf dem Schlauch. Zwei Comports erstellen kann ich, aber weiter irgendwie nicht? :oops:

Ansonsten habe ich erstmal sowas hier, furchtbar. Das nahe an dem Messpunkt ist der interne Algorithmus des 7P. Das andere sollte mit den IGS daten harmonieren :)

Bild


Ich habe das ganze auch noch etwas größer:

Bild

Ich kann die files auch zur Verfügung stellen. Stefan kläre mich bitte mal auf, wie ich beides gleichzeitig verwenden kann und dann mache ich das morgen in aller frühe. :D

Micha
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon Hagen.Felix » 18.09.2014 - 18:14

micha83 hat geschrieben:OH Moment, aber um den Ublox Empfänger mit der RTKlib zum Leben zu erwecken muss ich doch den in den Rohdaten-Modus setzen, oder sehe ich das Falsch? Und dann ist doch der normale UBX modus hin, oder nicht? ...

Zum Glück nicht ... :mrgreen:

Beim NEO-7P kann für jeden Ausgang (USB, UART1 usw.) jede beliebige Mischung aus NMEA und UBX eingestellt werden. :D

RTKNAVI hat auch kein Problem damit, wenn außer den benötigten UBX-RXM-RAW und UBX-RXM-SFRB noch mehr Nachrichten eintrudeln ... :wink:
Gewerbliche Tätigkeit u.a. im Bereich GNSS (siehe https://www.optimalsystem.de/os.aspx?x=411)
Nachrichten bitte bevorzugt als klassische E-Mail (siehe https://www.optimalsystem.de/os.aspx?x=8)
Hagen.Felix
 
Beiträge: 652
Registriert: 21.12.2008 - 12:07
Wohnort: Grimma

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 19.09.2014 - 15:31

Ahja, vielen dank. Ist schon ganz schön erstaunlich. :D Ich habe auch schon bei Regenschauern heute morgen eine Messung gemacht, die ich euch nicht vorenthalten möchte. :lol:

Auf dem linken Bild befindet sich ein direkter Vergleich zwischen den Interne PPP des NEO 7P und dem PPP der RTKlib. Die Einstellungen der RTKlib würde ich hinzufügen.
Auf dem rechten Foto unten ist zum Vergleich nochmal eine Messung mit dem SAPOS HEPS dienst, auch zeitgleich gemacht. :D :D

Bild


Leider verstehe ich immer noch nicht, warum der PPP Algorithmus der RTKlib so hinundher wandert. :cry: Da ich die Einstellungen auch SBAS stellte, dachte ich mindestens, dass der fast das gleiche Ergebnis bring wie mit dem Internen des NEO7P´s.

Die EInstellungen von RTKNAVI, die ich verwendet habe:

pos1-posmode =ppp-static
pos1-frequency =l1
pos1-soltype =forward
pos1-elmask =15
pos1-snrmask_r =off
pos1-snrmask_b =off
pos1-dynamics =on
pos1-tidecorr =off
pos1-ionoopt =sbas
pos1-tropopt =sbas
pos1-sateph =brdc
pos1-posopt1 =on
pos1-posopt2 =on
pos1-posopt3 =on
pos1-posopt4 =on
pos1-posopt5 =on
pos1-exclsats =
pos1-navsys =7
pos2-gloarmode =on
pos2-arthres =3
pos2-arlockcnt =0
pos2-arelmask =0
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon archie » 19.09.2014 - 19:45

Hallo Micha,

Die Einstellung :"pos1-sateph =brdc " mußt du wohl ändern in "sbas + brdc", wenn du Egnos voll benutzen wollst wie es ublox intern bestimmt auch tut.
Oder du benutzt präzise Emphemeris.

Grüße Pieter.
archie
 
Beiträge: 32
Registriert: 11.04.2010 - 14:55

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 30.09.2014 - 13:29

Hallo Pieter,

vielen Dank :D . Nach einer kleinen Auszeit bin ich wieder zurück. Ich habe die Einstellung geändert und bekomme folgendes Ergebnis:
Es sieht wesentlich zufriedenstellender aus :)

Bild



Die Präzisen Emphemeris möchte ich auch gern ausprobrobieren, bekomme da aber meines Achtens ein wesentlich schlechteres Ergebnis: :?

Bild

Ich lade diese doch von diesem Server runter oder? cddis.gsfc.nasa.gov/gps/products/%W/igu%W%D_%hb.sp3.Z

Weitere Einstellungen sind diese:

pos1-posmode =ppp-static # (0:single,1:dgps,2:kinematic,3:static,4:movingbase,5:fixed,6:ppp-kine,7:ppp-static)
pos1-frequency =l1 # (1:l1,2:l1+l2,3:l1+l2+l5,4:l1+l2+l5+l6,5:l1+l2+l5+l6+l7)
pos1-soltype =forward # (0:forward,1:backward,2:combined)
pos1-elmask =15 # (deg)
pos1-snrmask_r =off # (0:off,1:on)
pos1-snrmask_b =off # (0:off,1:on)
pos1-dynamics =off # (0:off,1:on)
pos1-tidecorr =on # (0:off,1:on)
pos1-ionoopt =est-stec #
pos1-tropopt =est-ztdgrad #
pos1-sateph =precise #
pos1-posopt1 =on # (0:off,1:on)
pos1-posopt2 =on # (0:off,1:on)
pos1-posopt3 =on # (0:off,1:on)
pos1-posopt4 =on # (0:off,1:on)
pos1-posopt5 =on # (0:off,1:on)
pos1-exclsats = # (prn ...)
pos1-navsys =7 # (1:gps+2:sbas+4:glo+8:gal+16:qzs+32:comp)
pos2-armode =fix-and-hold



Hast du da vielleicht auch eine Idee?

Grüße Micha
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46

Re: Erfahrungen mit RTKnavi mit NEO7P und IGS

Beitragvon micha83 » 10.12.2014 - 18:28

Hallo Community, gibt es Erfahrungen mit den PPP-Algorithmus und des RTKpost bzw. hat jemand ähnliche Erfahrungen gesammelt?
Also mein Ziel ist es, den PPP Algorithmus besser zu verstehen. Also ich nutze nachwievor den den Neo 7P und die TW4421.

Also erstmal meine Einstellungen mit denen ich unter freier Sicht, ein gutes Ergebnis erzielte, so denke ich zumindest :D .

Achso die Rinexdaten habe ich auch mit der RTKlib erstellt.

Bild

So nun zu meinen ersten Ergebnis: :arrow:

Bild


So und ohne, dass ich irgendwas an den Einstellungen ändere oder Datein austausche, lediglich nur neu berechne, bekomme ich das: :shock:

Bild



Kann sich das jemand erklären? Wenn ich RTKpost beende und neu starte habe ich den gleichen Effekt. :?:

Ich kann auch die Ionex Tec file verwenden, aber dann sieht das Ergebnis bei weitem nicht so toll aus (+70 cm entfernt). Dann habe ich diesen Effekt nicht mehr. Das ich das zweimal hintereinander Berechnen lassen muss, liegt irgendwie an den SBAS Einstellungen. Aber Warum? Oder sind die Korrekturdaten irgendwie falsch, hab die mit RTKget runtergeladen?
micha83
 
Beiträge: 15
Registriert: 28.01.2014 - 15:46


Zurück zu GPS in der Praxis

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron